Lightning component not visible to community members

The name of the pictureThe name of the pictureThe name of the pictureClash Royale CLAN TAG#URR8PPP

up vote
1
down vote

favorite

So I have a lightning component

<aura:component implements="forceCommunity:availableForAllPageTypes" access="global" controller="GSTAR_LGHT_CTRL">
<aura:attribute name="accs" type="Account"/>

<aura:handler name="init" action="{!c.doInit}" value="{!this}"/>

<lightning:layout>
    <lightning:layoutItem padding="around-small" size="6">
        <lightning:card title="My Brand new Lightning Component">
....

And it shows up in my Community Builder. And I am able to publish my community builder and set it as the landing page for my community.
But when I log in as a community user my Lightning Component is just not there. All the other components from the Builder show up.
So what am I missing?

share|improve this question

  • Did you receive community published successfully email before loging in and trying?
    – Pranay Jaiswal
    Nov 29 at 12:41

  • @PranayJaiswal, yes.
    – AvailableName
    Nov 29 at 12:42

  • Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
    – Pranay Jaiswal
    Nov 29 at 12:43

  • @PranayJaiswal Yup. That profile has access.
    – AvailableName
    Nov 29 at 12:47

  • It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
    – Pranay Jaiswal
    Nov 29 at 12:51

up vote
1
down vote

favorite

So I have a lightning component

<aura:component implements="forceCommunity:availableForAllPageTypes" access="global" controller="GSTAR_LGHT_CTRL">
<aura:attribute name="accs" type="Account"/>

<aura:handler name="init" action="{!c.doInit}" value="{!this}"/>

<lightning:layout>
    <lightning:layoutItem padding="around-small" size="6">
        <lightning:card title="My Brand new Lightning Component">
....

And it shows up in my Community Builder. And I am able to publish my community builder and set it as the landing page for my community.
But when I log in as a community user my Lightning Component is just not there. All the other components from the Builder show up.
So what am I missing?

share|improve this question

  • Did you receive community published successfully email before loging in and trying?
    – Pranay Jaiswal
    Nov 29 at 12:41

  • @PranayJaiswal, yes.
    – AvailableName
    Nov 29 at 12:42

  • Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
    – Pranay Jaiswal
    Nov 29 at 12:43

  • @PranayJaiswal Yup. That profile has access.
    – AvailableName
    Nov 29 at 12:47

  • It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
    – Pranay Jaiswal
    Nov 29 at 12:51

up vote
1
down vote

favorite

up vote
1
down vote

favorite

So I have a lightning component

<aura:component implements="forceCommunity:availableForAllPageTypes" access="global" controller="GSTAR_LGHT_CTRL">
<aura:attribute name="accs" type="Account"/>

<aura:handler name="init" action="{!c.doInit}" value="{!this}"/>

<lightning:layout>
    <lightning:layoutItem padding="around-small" size="6">
        <lightning:card title="My Brand new Lightning Component">
....

And it shows up in my Community Builder. And I am able to publish my community builder and set it as the landing page for my community.
But when I log in as a community user my Lightning Component is just not there. All the other components from the Builder show up.
So what am I missing?

share|improve this question

So I have a lightning component

<aura:component implements="forceCommunity:availableForAllPageTypes" access="global" controller="GSTAR_LGHT_CTRL">
<aura:attribute name="accs" type="Account"/>

<aura:handler name="init" action="{!c.doInit}" value="{!this}"/>

<lightning:layout>
    <lightning:layoutItem padding="around-small" size="6">
        <lightning:card title="My Brand new Lightning Component">
....

And it shows up in my Community Builder. And I am able to publish my community builder and set it as the landing page for my community.
But when I log in as a community user my Lightning Component is just not there. All the other components from the Builder show up.
So what am I missing?

lightning-components community community-builder

share|improve this question

share|improve this question

share|improve this question

share|improve this question

asked Nov 29 at 12:33

AvailableName

353111

353111

  • Did you receive community published successfully email before loging in and trying?
    – Pranay Jaiswal
    Nov 29 at 12:41

  • @PranayJaiswal, yes.
    – AvailableName
    Nov 29 at 12:42

  • Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
    – Pranay Jaiswal
    Nov 29 at 12:43

  • @PranayJaiswal Yup. That profile has access.
    – AvailableName
    Nov 29 at 12:47

  • It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
    – Pranay Jaiswal
    Nov 29 at 12:51

  • Did you receive community published successfully email before loging in and trying?
    – Pranay Jaiswal
    Nov 29 at 12:41

  • @PranayJaiswal, yes.
    – AvailableName
    Nov 29 at 12:42

  • Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
    – Pranay Jaiswal
    Nov 29 at 12:43

  • @PranayJaiswal Yup. That profile has access.
    – AvailableName
    Nov 29 at 12:47

  • It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
    – Pranay Jaiswal
    Nov 29 at 12:51

Did you receive community published successfully email before loging in and trying?
– Pranay Jaiswal
Nov 29 at 12:41

Did you receive community published successfully email before loging in and trying?
– Pranay Jaiswal
Nov 29 at 12:41

@PranayJaiswal, yes.
– AvailableName
Nov 29 at 12:42

@PranayJaiswal, yes.
– AvailableName
Nov 29 at 12:42

Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
– Pranay Jaiswal
Nov 29 at 12:43

Also can you check if you have provided Access to Class “GSTAR_LGHT_CTRL” to community user profile?
– Pranay Jaiswal
Nov 29 at 12:43

@PranayJaiswal Yup. That profile has access.
– AvailableName
Nov 29 at 12:47

@PranayJaiswal Yup. That profile has access.
– AvailableName
Nov 29 at 12:47

It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
– Pranay Jaiswal
Nov 29 at 12:51

It should work, Its very strange. Can you remove init handler in your code, save and then try refreshing the community?
– Pranay Jaiswal
Nov 29 at 12:51

1 Answer
1

active

oldest

votes

up vote
4
down vote

accepted

Check the objects referred in component by the Community site User have access to that Object in Profile Settings. If not, the component won’t be displayed.

share|improve this answer

  • 1

    The profile in use for this community did not have read access to the Account object. Setting that fixed it.
    – AvailableName
    Nov 29 at 13:51

Your Answer

StackExchange.ready(function() {
var channelOptions = {
tags: “”.split(” “),
id: “459”
};
initTagRenderer(“”.split(” “), “”.split(” “), channelOptions);

StackExchange.using(“externalEditor”, function() {
// Have to fire editor after snippets, if snippets enabled
if (StackExchange.settings.snippets.snippetsEnabled) {
StackExchange.using(“snippets”, function() {
createEditor();
});
}
else {
createEditor();
}
});

function createEditor() {
StackExchange.prepareEditor({
heartbeatType: ‘answer’,
convertImagesToLinks: false,
noModals: true,
showLowRepImageUploadWarning: true,
reputationToPostImages: null,
bindNavPrevention: true,
postfix: “”,
imageUploader: {
brandingHtml: “Powered by u003ca class=”icon-imgur-white” href=”https://imgur.com/”u003eu003c/au003e”,
contentPolicyHtml: “User contributions licensed under u003ca href=”https://creativecommons.org/licenses/by-sa/3.0/”u003ecc by-sa 3.0 with attribution requiredu003c/au003e u003ca href=”https://stackoverflow.com/legal/content-policy”u003e(content policy)u003c/au003e”,
allowUrls: true
},
onDemand: true,
discardSelector: “.discard-answer”
,immediatelyShowMarkdownHelp:true
});

}
});

draft saved
draft discarded

StackExchange.ready(
function () {
StackExchange.openid.initPostLogin(‘.new-post-login’, ‘https%3a%2f%2fsalesforce.stackexchange.com%2fquestions%2f240940%2flightning-component-not-visible-to-community-members%23new-answer’, ‘question_page’);
}
);

Post as a guest

Required, but never shown

1 Answer
1

active

oldest

votes

1 Answer
1

active

oldest

votes

active

oldest

votes

active

oldest

votes

up vote
4
down vote

accepted

Check the objects referred in component by the Community site User have access to that Object in Profile Settings. If not, the component won’t be displayed.

share|improve this answer

  • 1

    The profile in use for this community did not have read access to the Account object. Setting that fixed it.
    – AvailableName
    Nov 29 at 13:51

up vote
4
down vote

accepted

Check the objects referred in component by the Community site User have access to that Object in Profile Settings. If not, the component won’t be displayed.

share|improve this answer

  • 1

    The profile in use for this community did not have read access to the Account object. Setting that fixed it.
    – AvailableName
    Nov 29 at 13:51

up vote
4
down vote

accepted

up vote
4
down vote

accepted

Check the objects referred in component by the Community site User have access to that Object in Profile Settings. If not, the component won’t be displayed.

share|improve this answer

Check the objects referred in component by the Community site User have access to that Object in Profile Settings. If not, the component won’t be displayed.

share|improve this answer

share|improve this answer

share|improve this answer

answered Nov 29 at 13:13

Pranay Jaiswal

12.3k32251

12.3k32251

  • 1

    The profile in use for this community did not have read access to the Account object. Setting that fixed it.
    – AvailableName
    Nov 29 at 13:51

  • 1

    The profile in use for this community did not have read access to the Account object. Setting that fixed it.
    – AvailableName
    Nov 29 at 13:51

1

1

The profile in use for this community did not have read access to the Account object. Setting that fixed it.
– AvailableName
Nov 29 at 13:51

The profile in use for this community did not have read access to the Account object. Setting that fixed it.
– AvailableName
Nov 29 at 13:51

draft saved
draft discarded

Thanks for contributing an answer to Salesforce Stack Exchange!

  • Please be sure to answer the question. Provide details and share your research!

But avoid

  • Asking for help, clarification, or responding to other answers.
  • Making statements based on opinion; back them up with references or personal experience.

To learn more, see our tips on writing great answers.

Some of your past answers have not been well-received, and you’re in danger of being blocked from answering.

Please pay close attention to the following guidance:

  • Please be sure to answer the question. Provide details and share your research!

But avoid

  • Asking for help, clarification, or responding to other answers.
  • Making statements based on opinion; back them up with references or personal experience.

To learn more, see our tips on writing great answers.

draft saved

draft discarded

StackExchange.ready(
function () {
StackExchange.openid.initPostLogin(‘.new-post-login’, ‘https%3a%2f%2fsalesforce.stackexchange.com%2fquestions%2f240940%2flightning-component-not-visible-to-community-members%23new-answer’, ‘question_page’);
}
);

Post as a guest

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Required, but never shown

Related Post

Leave a Reply

Your email address will not be published. Required fields are marked *